【cakephp3.6】Class ‘App\Controller\Google_Client’ not foundエラー

作業環境

cakephp3.6
centos6.9
apache2.4
mysql5.6
php7.1

概要

cakephp3.6でGoogleのApiを使おうとしたところこういうエラーが出ました。
Class ‘App\Controller\Google_Client’ not found

やったこと

compserでインストールしたんだけどなんでうまく使えないんだ? と思って下記のようなことをしたりしてがんばっていました。
requre(‘vender/autoload.php’)
requre(‘vender/Google/src/autoload.php’)

でも結局、使いたいclassをファイルの頭でuseするだけでいけました。
何だそんなに簡単だったのか…、常識なんだろうな…。って今思ってるところです。

use Google_Client;

(中略)
public function func()
{
	// 上記のようにuse Google_Client するとここでnew時に出ていたエラーが出なくなる
	$client = new Google_Client();
}

おわり。